Sibps72.ru

Связь и интернет
13 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Cisco роутер для дома

Начальная настройка маршрутизатора Cisco. Доступ в Интернет.

Read the article BASIC CONFIGURATION OF THE CISCO ROUTER. ACCESS TO THE INTERNET in English

Рассмотрим схему подключения офиса к сети Интернет с помощью маршрутизатора Cisco. Для примера возьмем модель Cisco 881. Команды для настройки других маршрутизаторов (1841, 2800, 3825…) будут аналогичными Различия могут быть в настройке интерфейсов, вернее в их названиях и нумерации.

В схеме присутствуют:

  • канал в Интернет со статическим адресом
  • несколько компьютеров в локальной сети офиса
  • маршрутизатор
  • коммутатор, который используется для организации локальной сети офиса

Задача: обеспечить доступ компьютеров локальной сети в Интернет.

Шаг 0. Очистка конфигурации

Первое, с чего стоит начать настройку нового маршрутизатора – полностью очистить стартовую конфигурацию устройства. ( Выполнять только на новом или тестовом оборудовании! ) Для этого нужно подключиться с помощью специального кабеля к консольному порту маршрутизатора, зайти в командную строку и выполнить следующее:

Войти в привилегированный режим(#), возможно потребуется ввести логин/пароль.
router> enable
Удалить стартовую конфигурацию
router# write erase
/подтверждение/
Перезагрузить маршрутизатор
router# reload
/подтверждение/
После выполнения маршрутизатор должен перезагрузиться в течение 3ех минут, а при старте вывести запрос о начале базовой настройки. Следует отказаться.
Would you like to enter the basic configuration dialog (yes/no): no
В текущей конфигурации маршрутизатора будут только технологические строки по умолчанию, и можно приступать к основной настройке.

Шаг 1. Имя устройства

Задание имени маршрутизатора для удобства последующего администрирования выполняется командой hostname «название устройства»
router# conf t
router (config)# hostname R-DELTACONFIG
R-DELTACONFIG (config)#

Шаг 2. Настройка интерфейсов

Необходимо настроить 2 интерфейса: внешний и внутренний.
Через внешний интерфейс будет осуществляться связь с Интернет. На нем будут те ip адрес и маска сети, которые предоставил Интернет провайдер.
Внутренний интерфейс будет настроен для локальной сети 192.168.0.0 /24

Предположим, что оператор связи предоставил нам следующие адреса:

  • Сеть 200.150.100.0
  • Маска подсети 255.255.255.252 или /30
  • Шлюз по умолчанию 200.150.100.1

Настроим внешний интерфейс: зададим ip адрес и сетевую маску, и включим его командой no shut
R-DELTACONFIG#conf t
R-DELTACONFIG (config)#
interface Fa 4
ip address 200.150.100.2 255.255.255.252
no shutdown
После этого соединяем этот интерфейс маршрутизатора с портом оборудования провайдера при помощи прямого патч корда и далее проверяем его доступность командой ping.

Сначала собственный интерфейс
R-DELTACONFIG# ping 200.150.100.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.150.100.2, timeout is 2 seconds:
.
Success rate is 100 percent (5/5) , round-trip min/avg/max = 1/1/4 ms
Затем соседний адрес — шлюз провайдера
R-DELTACONFIG# ping 200.150.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.150.100.1, timeout is 2 seconds:
.
Success rate is 100 percent (5/5) , round-trip min/avg/max = 2/4/10 ms
Убедившись в доступности шлюза Провайдера, переходим к настройке внутреннего интерфейса.

В локальной сети будет использоваться следующая адресация

  • Сеть 192.168.0.0
  • Маска подсети 255.255.255.0
  • Внутренний адрес маршрутизатора, который выполняет роль шлюза в Интернет для всех хостов в сети, 192.168.0.1
  • Диапазон внутренних адресов сети (пользователи, принтеры, серверы и.т.д.) советую начинать с адреса 192.168.0.5
  • Максимально возможный доступный для использования адрес в этой сети будет 192.168.0.254
  • Адреса с 192.168.0.2 до 192.168.0.4 оставим про запас для непредвиденных технологических нужд

Для настройки внутреннего интерфейса локальной сети следует зайти в режим конфигурирования виртуального интерфейса Vlan 1, задать на нем ip адрес и соотнести ему один из физических интерфейсов маршрутизатора (Fa 0).
R-DELTACONFIG#conf t
interface Vlan 1
Ip address 192.168.0.1 255.255.255.0
no shutdown
Выбираем физический интерфейс маршрутизатора и соотносим его с виртуальным Vlan
interface Fa 0
switchport access vlan 1
no shutdown
Для наглядности:

ip address => interface Vlan X => interface Fastethernet Y
Ip адрес присваивается виртуальному интерфейсу Vlan X, а он привязывается к физическому интерфейсу Fastethernet Y.

Интерфейс маршрутизатора Fa 0 нужно соединить с коммутатором, где располагаются рабочие станции локальной сети или напрямую с рабочей станцией администратора. После этого проверить доступность этого интерфейса маршрутизатора с помощью ping из командной строки.

Шаг 3 Настройка удаленного доступа к маршрутизатору

Получить доступ к консоли маршрутизатора можно не только с помощью консольного кабеля, но и удаленно с помощью протоколов Telnet(данные передаются в открытом виде) или SSH(защищенное соединение).
Рассмотрим настройку безопасного подключения.
Включаем протокол SSH 2 версии и задаем произвольное имя домена
R-DELTACONFIG (config)#
ip ssh ver 2
ip domain-name xxx.ru
Генерируем ключи rsa, необходимые для подключения. При запросе указываем 1024.
crypto key generate rsa
How many bits in the modulus [512]: 1024
Задаем имя пользователя с правами администратора и его пароль (*****)
username admin privilege 15 secret 0 *****
Включаем авторизацию через локальную базу устройства (тот пользователь, которого создали строчкой выше)
line vty 0 4
login local
Задаем пароль на привилегированный режим
enable secret 0 *****
После этого при помощи специальной программы, поддерживающей протокол SSH можно зайти в командную строку маршрутизатора удаленно с любой из рабочих станций локальной сети. При авторизации следует ввести логин и пароль, которые были задан. Подробнее про доступ на устройство по протоколу SSH написано в этой статье.

Шаг 4. Шлюз по умолчанию

Для маршрутизации пакетов в сеть Интернет на устройстве необходимо указать шлюз по умолчанию(default gateway).
R-DELTACONFIG (config)#
ip route 0.0.0.0 0.0.0.0 200.150.100.1
После этого можно проверить не только доступность оборудования провайдера, но и полностью канала в Интернет. Для этого необходимо запустить ping до любого адреса во внешней сети в цифровой форме(DNS для локальной сети лучше настраивать после настройки маршрутизатора). Для примера возьмем адрес лидера на рынке ping – www.yandex.ru (93.158.134.3)
R-DELTACONFIG#ping 93.158.134.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 93.158.134.3, timeout is 2 seconds:
.
Success rate is 100 percent (5/5) , round-trip min/avg/max = 1/5/10 ms

Важно!
Обратите внимание, что на данный момент ping внешних адресов работает только(!) будучи запущенным из консоли управления маршрутизатором. Рабочие станции локальной сети все еще не имеют доступа в Интернет.

Шаг 5 Настройка трансляции адресов (NAT)

Для доступа в Интернет из локальной сети необходимо динамически транслировать все внутренние адреса в определенный внешний ip адрес. В нашем случае, так как провайдер предоставляет только один внешний адрес 200.150.100.2 (определяется маской подсети /30 в условиях примера), то все адреса локальной сети должны транслироваться в него.
Указываем список внутренних адресов, которые будем транслировать во внешний адрес.
R-DELTACONFIG (config)#
ip access-list standard ACL_NAT
permit 192.168.0.0 0.0.0.255
Указываем внутренний интерфейс для процедуры трансляции
Interface Vlan 1
ip nat inside
Указываем внешний интерфейс для процедуры трансляции
Interface Fa 4
ip nat outside
Создаем правило трансляции (NAT)
ip nat inside source list ACL_NAT interface fa4
В результате должен появиться доступ с любой рабочей станции локальной сети в Интернет при условии, что шлюзом по умолчанию указан внутренний ip адрес маршрутизатора (192.168.0.1). Проверить можно с помощью команды ping до адреса в Интернет из командной строки. Желательно, чтобы проверяемый адрес был в цифровом виде, чтобы исключить потенциальные проблемы с DNS именами.

Читать еще:  Роутер wifi плохой сигнал

Важно!
В указанном примере меняется собственный адрес источника. Если в процессе работы необходимо транслировать адрес назначения — пускать траффик на вымышленный адрес, чтобы попасть на некий настоящий, то прочитайте статью ip nat outside.

Важно!
Не стоит оставлять полный доступ в Интернет со всех адресов локальной сети. Советую после проверки работоспособности соединения для безопасности ограничить доступ в Интернет и разрешить его только с конкретных адресов — например с прокси сервера и рабочих станций администратора и/или директора. О том как это сделать можно прочитать в статье «немного об access lists«.

Важно!

Не забудьте сохранить конфигурацию на всех устройствах командой write или copy run start. Иначе после перезагрузки все изменения будут потеряны.
R-DELTACONFIG# write
Building configuration.
[OK]

Выбираем роутер Cisco для дома

В наше время куча проводов в квартире уже никого не устраивает, да и образ жизни требует мобильности. Поэтому, в массах с удовольствием были приняты беспроводные сетевые устройства, которые теперь используются повсюду. Для создания домашней беспроводной сети часто используется роутер Cisco, как надёжный, зарекомендовавший себя девайс.

Оборудование Cisco можно использовать для любой сети и провайдеров

Сетевое оборудование Cisco

Роутер от Cisco — надёжное, простое в настройке, мощное и функциональное сетевое устройство для дома, обеспечивающее быстрый и стабильный доступ в интернет и к домашней сети. Оно вполне может подойти самым продвинутым пользователям, но в то же время идеально подходит и начинающим.

Большой ассортимент роутеров Cisco позволяет:

  • подобрать оптимальный вариант для любого провайдера;
  • использовать кабельный интернет, ADSL, 3G, 4G;
  • раздавать интернет по Wi-Fi в помещениях любого размера;
  • подключать необходимое количество Wi-Fi устройств к домашней беспроводной сети.

Роутеры Linksys by Cisco

Линейка роутеров Linksys by Cisco появилась на рынке сетевых устройств после покупки транснациональной компанией Cisco (изначально специализирующейся на сетевом оборудовании для серьёзных предприятий) своего чуть более молодого американского конкурента — Linksys (чьей целью было обеспечить интернетом каждый дом). Для Cisco этот ход стал отличной возможностью расширить свой ассортимент, предложив роутеры для дома, выдающиеся своими впечатляющими характеристиками и возможностями, но имеющие, в то же время, вполне приемлемую для обычных семей цену.

Используя сетевые устройства Linksys by Cisco, можно в собственной квартире не только настроить доступ в интернет, управлять принтерами, телевизорами и другими приборами, но и организовать вполне серьёзную сеть для удобного хранения и обмена информации, а также защищённого доступа к ней.

Простота и удобство в настройке и использовании домашних маршрутизаторов Cisco Linksys гармонично сочетаются с инновационным дизайном.

Модельный ряд роутеров Cisco Linksys E-Series

Роутеры этой серии ориентированы на простую настройку домашней точки доступа, они достаточно универсальны и подходят для большинства даже самых требовательных пользователей.

  • функции повышенной безопасности (включая SPI Firewall);
  • стабильность работы;
  • возможность настройки удалённого доступа к домашней сети;
  • технология Quality of Service позволяет управлять приоритетами трафика и запускать мультимедийные файлы в хорошем качестве;
  • использование метода передачи данных при помощи антенных систем (MIMO), благодаря которому, улучшается сигнал и не образуется зон с нулевым сигналом;
  • скорость до 450 Мбит/с;
  • применение технологии Dual-Band для увеличения пропускной способности;
  • способность одновременно работать в двух диапазонах, что не ограничивает скорость передачи данных при подключении Wi-Fi-устройств с разными стандартами IEEE;
  • технология SpeedBoost улучшает силу и дальность сигнала Wi-Fi;
  • наличие USB-разъёма;
  • поддержка UPnP, обеспечивающая удобное и простое подключение мультимедийных устройств;
  • ПО Cisco Connect, при помощи которого можно настроить гостевой доступ, родительский контроль и управлять другими параметрами;
  • небольшой размер;
  • стильный дизайн.

Для повседневного доступа в интернет идеально подойдут модели E1200 и E1500, предназначенные для использования в помещениях стандартного размера. Эти роутеры легко справятся с такими задачами, как просмотр веб-страниц, работа с электронной почтой и печать через Wi-Fi.

При активном пользовании интернета, стоит обратить внимание на модель E2500, которая подойдёт для эксплуатации в достаточно просторных помещениях. Кроме выполнения повседневных задач в больших объёмах, этот двухдиапазонный роутер для дома позволит работать с мультимедийными файлами, например, играми и видео.

Если необходимо обеспечить большое количество человек быстрым интернетом, подключить одновременно много устройств к сети Wi-Fi, обеспечить постоянно пополняемым контентом домашний кинотеатр — модель E3200 (также двухдиапазонная) станет оптимальным вариантом.

Ну а если интернет нужен для использования в больших помещениях, к примеру, коттеджах? И при этом важно передавать и получать большие объёмы информации, комфортно играть в игры и смотреть HD видео, подключать множество различных Wi-Fi-устройств в любом уголке дома, то лучший выбор — E4200 (не просто двухдиапазонный, а обладающий невероятным числом прочих возможностей роутер). Поистине, стильный красавец Cisco Linksys E4200 обладает весьма скромными размерами (22,5×16 см при толщине в 2,5 см) и ненавязчивой индикацией, но это не мешает ему обладать флагманскими характеристиками.

Интересной и заслуживающей внимания является модель E2100L, работающая на базе Linux. Как заявляет производитель, этот роутер предоставляет возможность гибкой настройки точки доступа средствами Linux. По остальным параметрам, девайс вполне достоин принадлежать к линейке Cisco Linksys E-Series.

Читать еще:  Плохо работает wifi роутер

Модельный ряд роутеров Cisco Linksys X-Series

Роутеры X-Series удобны для тех, кто активно использует ADSL, они также позволяют без головной боли настроить дома точку доступа и могут помимо выполнения функций маршрутизатора, выступать в роли коммутатора.

К этой серии относятся модели X2000 и X3000. Оба эти сетевых устройства обладают приятным дизайном, но по компактности слегка уступают E-Series. С задачей настройки домашней точки доступа и беспроводной локальной сети, подключением различных Wi-Fi-устройств и стабильным высокоскоростным доступом в интернет, роутеры X-Series справляются отлично.

Роутеры Cisco Valet

Роутеры Cisco Valet — ещё одна линейка довольно симпатичных и удобных сетевых устройств для комфортной настройки домашней точки доступа. Отличаются они тем, что вообще не требуют редактировать конфигурацию вручную, чем и сыскали расположение большого числа потребителей.

Настройка этих роутеров производится при помощи USB-накопителя Easy Setup Key, который прилагается к самому девайсу. Программное обеспечение, находящееся на «флешке», самостоятельно устанавливается и настраивается, не пугая громоздкими панелями управления и не требуя ввода кучи различной информации, в том числе и сложных паролей. Пользователю остаётся только использовать возможности роутера для своих нужд.

Разумеется, что если есть желание всё же поучаствовать в настройке, любители конфигураций смогут полностью контролировать процесс при помощи расширенных настроек.

При помощи Cisco Valet можно обеспечить Wi-Fi-доступ в обычной квартире стандартных размеров и в большом особняке. Линейка представляется двумя модификациями, ориентированными именно на размер помещения: Cisco Valet и Cisco Valet Plus.

Роутеры Cisco 3G и 4G

К сожалению, интернет «по проводам» может быть не всегда доступен. Причин для этого много — например, помещение не может быть подключено по техническим причинам, сбой работы провайдера, частые поездки и т. п.

Единственным выходом в такой ситуации становится интернет от сотовых операторов. И, с появлением LTE, нельзя пожаловаться на скорость — получилась вполне достойная замена выделенной линии. Поэтому, вполне логично, что здравомыслящие производители роутеров, в том числе и Cisco, позаботились снабдить свои продукты модемами для использования 3G и 4G.

Большую популярность в этой нише завоевали роутеры Cisco 3G 800 Series. Они не отличаются малыми размерами и выглядят весьма внушительно, но справляются с возложенными на них функциями очень достойно.

Что касается 4G, то можно обратить внимание на модули Cisco EHWIC-4G-LTE и маршрутизаторы C1921-4G, которые также весьма популярны среди большого количества людей.

Современные роутеры объединяют в себе и точку доступа, и функции маршрутизации. Что выбрать — каждый решает сам для себя, исходя из своих потребностей и возможностей.

WiFi Роутеры Cisco для дома в Балашихе

Wi-Fi роутер D-link DIR-842

Wi-Fi роутер Huawei B310

Wi-Fi роутер Xiaomi Mi Wi-Fi Router 4A Gigabit Edition

Wi-Fi роутер Apple Time Capsule 3Tb ME182

Wi-Fi роутер Xiaomi Mi Wi-Fi Router 4A

Wi-Fi роутер D-link DWR-953

Wi-Fi роутер Linksys WRT1900ACS

Wi-Fi роутер Linksys WRT3200ACM

Wi-Fi роутер ZYXEL VMG3625-T20A

Wi-Fi роутер ZYXEL USG20W-VPN

Роутер Cisco RV130W-E-K8-RU

Wi-Fi роутер TP-LINK Archer C1200

Потолочный WiFi Роутер / Точка доступа CC3AP241-C3-M (P.

Wi-Fi роутер Cisco RV130W

Wi-Fi роутер TP-LINK Archer C50(RU)

Wi-Fi роутер KHD Wi-Fi роутер CP450

Wi-Fi роутер ASUS RT-AC58U

Wi-Fi роутер TP-LINK Archer C7

Wi-Fi роутер Cisco WRT160NL

Wi-Fi роутер Cisco RV220W

Wi-Fi роутер D-link DAP-3860

Wi-Fi роутер TP-LINK Archer C20(RU)

Wi-Fi роутер Alcatel Link Zone

Wi-Fi роутер D-link DAP-2360

Wi-Fi роутер Linksys WRT54GL

Wi-Fi роутер Cisco AIR-CAP2602E

Wi-Fi роутер TP-LINK WBS510

RV215W-E-K9-G5 Cisco VPN роутер 5 IPSec, WIFI 802.11n.

Wi-Fi роутер Cisco AIR-AP1852E

Роутер Linksys WRT54GL

Wi-Fi роутер Linksys EA6900

Wi-Fi роутер ZYXEL LTE3302-M432

Wi-Fi роутер CISCO C881

Wi-Fi роутер EnGenius EWS320AP

Wi-Fi роутер TP-LINK Archer C5

Wi-Fi роутер D-link DWR-956

CISCO 1941W-E WIFI маршрутизатор 2 x GE RJ-45, 3 х EHWI.

Wi-Fi роутер Huawei B315S

Wi-Fi роутер Cisco AIR-CAP2702E

Wi-Fi роутер Linksys EA8500

Wi-Fi роутер Cisco WAP121

WiFi роутер WE1626

Wi-Fi роутер Cisco 881W-GN

Wi-Fi роутер Linksys WHW0103

Wi-Fi роутер D-link DWR-921

Wi-Fi-роутер Linksys WRT3200ACM

Сетевое оборудование Linksys LRT224-EU маршрутизатор Du.

Wi-Fi роутер Cisco AIR-LAP1041N

Роутер Linksys WRT3200ACM-RM2

Wi-Fi роутер Keenetic Duo (KN-2110)

Wi-Fi роутер Keenetic Giga (KN-1010)

Wi-Fi роутер Linksys EA9500

Wi-Fi роутер Linksys WAP300N

Сетевое оборудование Wi-Fi и Bluetooth Linksys WAP54G

Cisco 1812 как домашний роутер

Решил я найти замену своему D-Link DIR-300, т.к. держать качественное соединение с моим новым провайдером по L2TP он упорно отказывался, да и вообще железка морально устарела. Перечитав кучу обзоров домашних маршрутизаторов я понял, что, в принципе, они все одинаковые: с одинаковыми возможностями и скучным web-интерфейсом. А всякие плюшки, вроде внешних накопителей и торрент клиентов, мне и даром не надо. Квартира у меня маленькая, поэтому вариант установки отдельного компа по типу hp micro server не подходит, да и денег жалко.

Так уж сложилось, что живу я во Владивостоке и Япония у нас под боком, есть и неплохой, японский же, аукцион на котором продают все: от комиксов до автомобилей. Есть и раздел с серверным оборудованием, на котором я и начал свои поиски. Т.к. искал не для стойки, а для дома, то интересовало меня что-то вроде cisco 8хх серии. К сожалению таковых не нашлось, зато нашлись в большом количестве и по смешным ценам cisco 1812 , но с буквой j, единственное отличие которых от тех, что по ссылке выше — отсутствие wifi модуля. Не долго думая — заказал, через недельку получил.
Итак, что мы имеем:

Cisco IOS Software, C181X Software (C181X-ADVENTERPRISEK9-M), Version 15.0(1)M, RELEASE SOFTWARE (fc2)
Cisco 1812-J (MPC8500) processor (revision 0x400) with 118784K/12288K bytes of memory.
10 FastEthernet interfaces
1 ISDN Basic Rate interface
1 Virtual Private Network (VPN) Module
62592K bytes of ATA CompactFlash (Read/Write)

И что хотим получить:
Подключение к обычному домовому провайдеру, с локальными сервисами и L2TP туннелем во внешний мир, компьютера и ноутбука. Удаленное управление маршрутизатором по ssh и доступ на основной домашний компьютер по RDP. А так же dynamic dns.

Читать еще:  Роутер для дома цена качество
1. Общие настройки

Для начала подключимся к маршрутизатору через консольный порт (я использую PuTTY) и войдем в привилегированный режим:

Router>en
Router#

Первым делом изменим название нашего маршрутизатора на что-нибудь более приятное глазу, чем просто “Router” и добавим ему имя домена (это пригодится при дальнейшей генерации ключа rsa для настройки ssh), так-же добавим адреса dns серверов провайдера:

Router#conf t
Router(config)#hostname home
home(config)#ip domain-name home.lan
home(config)#ip name-server x.x.x.x
home(config)#ip name-server y.y.y.y

Далее скажем роутеру шифровать пароли и архивировать конфигурационный файл:

home(config)#service password-encryption
home(config)#service compress-config

Теперь создадим пользователя и пароль для удаленного доступа на роутер, пароль для входа в привилегированный режим и настроим локальную аутентификацию и авторизацию:

home(config)#username yourname secret yourpass
home(config)#enable secret your_enable_pass
home(config)#aaa new-model
home(config)#aaa authentication login default local
home(config)#aaa authorization exec default local

Осталось сгенерировать ключи, настроить ssh и сконфигурировать виртуальный терминал:

home(config)#crypto key generate rsa
home(config)#ip ssh version 2
home(config)#line vty 0 4
home(config-line)#exec-timeout 0 0
home(config-line)#transport preferred ssh
home(config-line)#transport input ssh
home(config-line)#exit

И на этом настройку базовой конфигурации можно считать законченной.

2. LAN

Наш маршрутизатор имеет полноценный управляемый восьми-портовый коммутатор, по умолчанию все его 8 портов находятся в первом VLANе. Можно каждый порт разнести в свой VLAN, но для обычной домашней локалки это совсем не надо, поэтому приступим к конфигурации первого и единственного VLAN:

home(config)#int vlan 1
home(config-if)#ip address 192.168.0.1 255.255.255.0
home(config-if)#no ip redirects
home(config-if)#no ip unreachables
home(config-if)#no ip proxy-arp
home(config-if)#no cdp enable
home(config-if)#ip nat inside
home(config-if)#load-interval 30
home(config-if)#exit

В принципе больше ничего и не нужно, т.к. все lan порты по умолчанию в первом vlan, то можно включать в них железо, настраивать адресацию и “локалка” готова. Для ленивых можно настроить еще dhcp сервер на маршрутизаторе:
Убираем адреса которые мы не хотим отдавать по dhcp

home(config)ip dhcp excluded-address 192.168.0.1 192.168.0.99
Home(config)ip dhcp excluded-address 192.168.0.111 192.168.0.254

Создаем пул dhcp

home(config)ip dhcp pool dhcp
home(dhcp-config)#import all
home(dhcp-config)#network 192.168.0.0 255.255.255.0
home(dhcp-config)#default-router 192.168.0.1
home(dhcp-config)#dns-server 192.168.1.1
home(dhcp-config)#domain-name home.lan
home(dhcp-config)#lease infinite

Теперь можно получать адреса динамически из диапазона 192.168.0.100 — 192.168.0.110

3. WAN

Мой провайдер выпускает в глобальную сеть посредством L2TP с динамическим внешним ip адресом, поэтому будем настраивать сам туннель и при его поднятии системой отсылать полученный ip адрес серверу dyndns.org
Начнем с настроек ddns, т.к. они будут использоваться при создании подключения к провайдеру:

home(DDNS-HTTP)#end

Тут есть один момент, дело в том, что в цисках по умолчанию на знак «?» выводится подсказка по командам, а как вы могли заметить, этот символ используется в строке url которая и обновляет ip адрес на dyndns. Поэтому копи-пэйст тут не сработает и придется писать url ручками, а для того чтобы вставить символ «?», перед ним необходимо нажать комбинацию клавиш «CTRL+v» и тогда «?» впечатается без проблем.
Далее сконфигурируем внешний ethernet интерфейс:

home(config)#interface FastEthernet0
home(config-if)#ip dhcp client update dns
home(config-if)#ip address dhcp
home(config-if)#ip nat outside
home(config-if)#load-interval 30
home(config-if)#end

В настройках ip адреса интерфейса мы указали dhcp, соответственно наш маршрутизатор будет получать от провайдера адрес для внутренней сети автоматически. Теперь создадим имя класса для нашего туннельного подключения:

home(config)l2tp-class «class name you like»

и сконфигурируем pseudowire класс (даже и не знаю как на русский это грамотно перевести):

home(config)#pseudowire-class «имя класса который создали ранее»
home(config-pw-class)#encapsulation l2tpv2
home(config-pw-class)#protocol l2tpv2 class1
home(config-pw-class)#ip local interface FastEthernet0

Ну и осталось, собственно создать сам туннельный интерфейс:

home(config)#int virtual-PPP 1
home(config-if)#ip ddns update hostname your-domain-on-dyndns.org
home(config-if)#ip ddns update dyndns
home(config-if)#ip address negotiated
home(config-if)#ip mtu 1454
home(config-if)#ip nat outside
home(config-if)#no ip virtual-reassembly
home(config-if)#ip tcp adjust-mss 1414
home(config-if)#ppp chap hostname username-from-your-isp
home(config-if)#ppp chap password pass-from-your-isp
home(config-if)#pseudowire x.x.x.x 10 pw-class «имя класса который создали ранее»
home(config-if)#end

В конфигурации туннеля есть 2 строчки которые вам могут не подойти:
ip mtu 1454 и ip tcp adjust-mss 1414. Без этих параметров данные передаваемые по туннелю фрагментировались и, соответственно, нормально ничего не работало.
По туннелю я не получал «маршрут по умолчанию», поэтому пришлось прописать его вручную:

home(config)#ip route 0.0.0.0 0.0.0.0 virtual-ppp 1 permanent

Так же у нас есть еще и локальная сеть провайдера, где нет ограничений по скорости и чтобы в нее попасть надо также прописать несколько маршрутов вручную, у меня это выглядит так:

home(config)ip route 10.0.0.0 255.0.0.0 FastEthernet0
home(config)ip route 172.16.0.0 255.240.0.0 FastEthernet0

У вас локальные подсети провайдера скорее всегу будут отличаться, необходимо уточнить у провайдера какие именно он использует.

4. NAT

После приведенных выше настроек, ваш туннель должен подняться и ваш маршрутизатор, теоретически, может бороздить просторы интернета, но мы же хотим в интернет выходить со своего компьютера, а не с маршрутизатора? Для этого необходимо настроить трансляцию адресов (NAT). В конфигурации интерфейсов мы уже прописали некоторые параметры, для того чтобы они (интерфейсы) работали в нужном нам режиме:
ip nat inside на интерфейсе vlan 10 и ip nat outside на интерфейсах FA0 и Virtual-PPP 1.
Осталось настроить сам NAT. Так как у нас фактически два направления наружу (локальная сеть провайдера и сам интернет), то выпускать трафик на эти направления мы будем через разные интерфейсы (FA0 и Vritual-PPP1). Делается это с помощью access-list ов:
Создаем 2 access-list, один для LAN, другой для WAN

home(config)ip access-list extended LAN
home(config-ext-nacl)#permit ip 192.168.0.0 0.0.0.255 172.16.0.0 0.15.255.255
home(config-ext-nacl)#permit ip 192.168.0.0 0.0.0.255 10.0.0.0 0.255.255.255
home(config-ext-nacl)#exit
home(config)ip access-list extended WAN
home(config-ext-nacl)#permit ip 192.168.0.0 0.0.0.255 any

и собственно NAT, все что направляется в локалку провайдера пускаем через FA0:

home(config)ip nat inside source list LAN interface FastEthernet0 overload

а все остальное — в virtual-ppp1:

home(config)ip nat inside source list WAN interface Virtual-PPP1 overload

В принципе на этом все, теперь мы должны с компьютера подключенного к циске, спокойно ходить в интернет. Если нужен RDP на какую-либо машину из вашей локальной сети — пробрасываем, с помощью того-же NAT, порты до этой машины:

home(config)ip nat inside source static tcp 192.168.0.100 3389 interface Virtual-PPP1 3389

Ссылка на основную публикацию
Adblock
detector